Распространенные ошибки программистов 1С


Главная - Проблемы с 1С - Распространенные ошибки программистов 1С


Объект
Описание ошибки Примеры
1
Запрос
Счетчик в запросе необходимо писать через ё, т.е. СЧЁТЧИК | Количество = счётчик(Док)
2
Процедура (Функция)
Точка с запятой после названия процедуры (функции) и скобок НЕ ставится МояПроцедура(а, в)
3
Процедура (Функция)
Если существуют процедуры (функции), которые стоят ниже чем вызывающая их процедура (функция), то необходимо указывать директивы "Далее" для этих процедур (функций)
Процедура ПроцедураКотораяВызыватеся() Далее
Процедура ИзКоторойВызывается()
...
ПроцедураКотораяВызывается()
...
КонецПроцедуры
ПроцедураКотораяВызывается()
...
КонецПроцедуры


4 Процедура (функция), переменная Чтобы переменную сделать видимой за пределами модуля необходимо наличие директивы Экспорт для этой переменной
в глобальном модуле:
МояПеременная Экспорт;
5 Форма Запрещается использовать одинаковые имена переменных и имена реквизитов формы
6 Периодический Для получения значения периодического реквизита НЕ забывайте указывать ИспользоватьДату()
7 Документ Попытка создать операцию для документа, в котором отсутствует принадлежность к бухгалтерскому учету, попытка создать движения по регистрам, в которых отсутствует принадлежность к оперативному учету
8 Радиокнопка Неправильная работа радиокнопки при неверном указании порядка обхода и указании первого в группе
9 Таблица Не забывайте при написании отчета писать Таб.Показать()
Таб = СоздатьОбъект("Таблица");
...
Таб.Показать()
10 Документ Не забывайте в конце модуля документа, принадлежащего к бух. учету писать Операция.Записать();
Процедура ОбработкаПроведения()
...
Операция.Записать();
КонецПроцедуры
11 Периодический Попытка записать периодический реквизит справочника из документа, у которого нет галочки "Изменяется документами" при вызове из процедуры ОбработкаПроведения()
12 Процедура (Функция) Не забывайте ставить ; после КонецПроцедуры (КонецФункции)